Monday, November 9, 2009

Simyo + Alcatel X060 + Ubuntu 9.10 (Karmic Koala)

Este post es para aquellos que tengáis el módem X060 que venía con la tarifa plana de Simyo y queráis utilizarlo con Ubuntu 9.10. Los que venís de Jaunty probablemente estaríais utilizando estas instrucciones, que ahora ya no funcionan.

Los problemas son varios: en primer lugar el módem ya está soportado por el kernel y no hace falta parchear el módulo "option", así que el paquete usb-modeswitch-alcatelX060-dkms_1.0.2-4_i386.deb que utilizábamos en Jaunty ya no hace falta en Karmic y se puede desinstalar:

sudo dpkg -r usb-modeswitch-alcatelX060-dkms

Segundo: ahora los problemas tienen que ver con el paquete "modemmanager", que es el que gestiona los módems 3G. Podéis ver los detalles aquí, esperemos que el autor los solucione. Mientras tanto podéis bajaros la versión parcheada haciendo:

sudo add-apt-repository ppa:jmartinj/x060-karmic
sudo apt-get update
sudo apt-get upgrade

Por otro lado necesitamos que el paquete usb-modeswitch esté instalado:

sudo apt-get install usb-modeswitch

Si todo ha ido bien, se habrá instalado el nuevo modemmanager que corrige este asunto. Reiniciad la máquina y probad.

¡Ya me diréis si os va!

EDITADO:
Viendo los comentarios parece que algunos tenéis problemas. Ahora que tengo un poco de tiempo puedo mirarlo, pero necesito que me mandéis un par de logs. Los que tengáis problemas haced esto:

Lo primero, desenchufad el módem. Luego abrís un terminal (Aplicaciones > Accesorios > Terminal) y ponéis:
sudo stop network-manager
sudo killall modem-manager
sudo modem-manager --debug >modem.log 2>&1

En otro terminal:
sudo NM_PPP_DEBUG=1 NetworkManager --no-daemon >nm.log 2>&1

Enchufad el módem y le dais a conectar. Lo dejáis 2 ó 3 minutos para que se conecte. Pasados esos 3 minutos le dais a CONTROL-C en los dos terminales y los cerráis.
Luego os vais a Lugares > Carpeta personal. Le dais con doble click a los dos ficheros de antes (nm.log y modem.blog) y se abrirán con el gedit. Copiáis todo y lo pegáis en pastebin.com. Pero antes buscad en el modem.log la palabra "PIN" y si aparece vuestro PIN lo borráis, para que no aparezca publicado. Al final el pastebin.com os dará un enlace por cada fichero, pues lo ponéis en los comentarios. Cuando tenga un rato lo miro e intento averiguar el problema.

42 comments:

RenKastle said...

Exelente! Funciona a la Perfección! (Probado con Alcatel X200!)

Saludos.

fran said...

Con Alcatel X060 en Kubuntu Karmic sólo funciona con wvdial.

Ni knetworkmanager ni nm-applet consiguen conectar.

Garrotix said...

Provado con alcatel X060+karmic y funciona.

Muchas gracias!!!

migaja said...

A mi no me funciona.Cuando le das a conectar se pone la luz en naranja y parpadeando, como cuando lo acabas de enchufar al usb y antes de que coja señal y se ponga verde, y no deja de parpadear hasta que lo quitas. Con el gnome-ppp funciona sin problemas. ¿Sabes que puede ser?

Felipe said...

Funciona a menudo en Ubuntu 9.10.
Pero hay veces en las que te aparece como conectado, pero te vas al navegador y sale como si no tuvieras conexión.

Simón said...

Gracias :), me ha funcionado. Para los demás visitantes que lleguen buscando esto, y seguirán llegando mientras no haya soporte oficial :), mi configuración es:
* Ubuntu Karmic Koala 9.10 64bits
* Modem 3G Alcatel X060S
* Conexión con Movidata (un operador de datos de The Phone House).

Gracias por el HOWTO :)

Javi said...

@migaja: no tengo ni idea, no se me ocurre qué puede ser.

@Felipe: a mí me pasa a veces, en mi caso es porque tarda en obtener una dirección por DHCP, pero al medio minuto o por ahí ya va.

migaja said...

Ya lo he arreglado hay que activarle el PIN. Sin el no funciona.

fran said...

@migaja: efectivamente, hay que volver a activar el PIN, gracias por el dato.
Ahora nm-applet se conecta correctamente como en Jaunty.

Lo he activado enviando a /dev/ttyUSB2 el comando:
AT+CLCK="SC",1,"xxxx"
donde xxxx es el PIN actual.
Gracias a Javier Martín por el arreglo del modemmanager.
SOLUCIONADO

Ric said...

Gracias. Funciona (aunque no siempre).
usb-modeswitch-alacatelX060-dkms_1.0.2-4_i386.deb no se deja desistalar --> no permite instalar el "correcto" (usb-modeswitch).

Mateo said...

Esperaba que me funcionara con el X030 pero no... imagino que este método no necesita la modificación en el GRUB que se usaba en la 9.04 o si?

De todas maneras gracias por el material ;-)

Javi said...

@Mateo: parece que el X030 trae un hardware diferente. Aquí dicen cómo configurarlo, lo hacen con el wvdial pero algo es algo:

http://dv51132la.wordpress.com/2009/01/31/configurar-alcatel-x030-en-gnulinux-comcel-3g/

Alberto said...

¡Cagüen tó! Funcionaba (regular, sólo regular) con Gnome, pero no va con KDE. Esto es una historia: un paso adelante y dos atrás :-(

undefined said...

Hola!! Hemos seguido los pasos de este post y nos ha funcionado de maravilla. Tenemos un modem alctatel x060 con Simyo, y la ubuntu netbook remix karmic koala (9.10). No es necesario usar el wvdial ni Gnome PPP, q es lo que habíamos instalado anteriormente en otro ordenador con una ubuntu 8.04. Uf!! que bieeeeeeeeeen!!!
muchísimas gracias.

Felipe said...

Hola Javi.
¿Estás seguro de que es de DHCP y que en un minuto se arregla?
A mí sigue sin navegarme. Mi forma de solucionarlo es darle a desconectar y conectar hasta que ya me deja ver webs.
¿Hay otra forma?
Gracias y enhorabuena por el blog!

Javi said...

@Felipe: pues yo le eché la culpa al dhcp pero es posible que falle alguna otra cosa. El problema es que ahora se me ha roto el módem y ya no puedo ni hacer pruebas.

ahoms said...

Ha funcionado despues de reiniciar y configurar la conexión en el network manager

Muchas gracias!!

Nestor said...

Hola disculpen pero el mio si conecta el x200 muestra la luz naranja pero a la hora de navegar nada es que si noo tuviera conexion alguien me podria ayudar en eso?

Felipe said...

Hola Javi.

A mí cada vez me tarda más en conectar.

¿Podrías poner las fuentes que usaste para hacer este post? Lo digo para mirar si han puesto actualizaciones, u otras formas para que funcione el modem.

Muchas gracias por anticipado

Javi said...

Felipe,

El parche al paquete modemmanager lo hice yo mismo, así que realmente la "fuente" es este post. Hice una entrada en el launchpad de ubuntu con la descripción del problema (mira el enlace "detalles aquí" de arriba) pero el autor del paquete original nunca llegó a contestar, por lo que me temo que la siguiente versión de ubuntu seguirá rota.

El problema es que mi modem de simyo está roto y ya no puedo hacer más pruebas, pero a bastante gente le va... No sé, ¿has probado a ver si tiene el mismo comportamiento en Windows?

Felipe said...

Hola Javi.

En Windows si me va bien. En Ubuntu también me funciona, pero a veces tengo que darle cinco y seis veces hasta que se conecta. Aun así, como dije antes, me suele pasar que aparece conectado, pero no me deja navegar. Por eso preguntaba si había alguna actualización ...

Con todo eso, gran trabajo.

Un saludo.

Roberto said...

Probado y funcionando en

S.O.: Ubuntu 9.10 Karmic Koala (no update)
Modem: Alcatel X060S
Proveedor: Simyo

Francisco said...

A mi mepasa exactamente lo mismo conecta cuando quiere y algunas veces esta conectado pero no puedo navegar,
OS: Ubuntu 10.04
Modem:Alcatel X060S
Simyo

jagaLinux said...

Hola, estoy haciendo un proyecto con varios beneficiarios y los tengo usando ubuntu, algunos de ellos tienen internet movil con el modem alcatel x060A, les realize el procedimiento mencionado y algunos equipos les resulto exitoso y hay otros que aparece el icono conectado, pero el firefox no entra a internet, ya revise la configuracion de proxy y esta todo bien (es decir no tiene configurado proxy), les agradezco me puedan colaborar con dicha situación. Gracias.

Javi said...

Hola, a los que tenéis problemas, especialmente del tipo "conecta pero no navega por internet" leed en el post original que he puesto unas instrucciones para sacar los logs y que los subáis aquí a ver si se puede averiguar el problema.

jagaLinux said...

Hola, ya copie los dos archivos en pastebin.com: http://pastebin.com/TUxW4Nmq
gracias por tu ayuda, quedo a la espera....

Javi said...

@jagaLinux: ¿Puedes hacer un pastebin del fichero /etc/resolv.conf y del resultado de ejecutar 'sudo route -n'?

jagaLinux said...

Hola, le envio lo que me dijiste, pero ocurrio algo raro, hoy cuando coloque el modem, este se conecto y se colocó verde, e ingreso a internet con el firefox normalmente, lo unico extraños que hice fue los comandos que me enviaste para obtener el modem.log etc..., estoy confundido con eso, de todas formas aca esta lo que me acabas de pedir:

http://pastebin.com/LEnvqkh2

spain said...

SALUDOS Y GRACIAS, yo tengo el ubuntu 9.10 instalado y el model alcatel x060s de simyo, el problema es que dado que no puedo conectarme a internet no puedo descargar nada desde ubuntu y no puedo (por torpeza o ignorancia) seguir las instrucciones que dais aqui, no estoy muy espabilado en esto, os pido que por favor pongais la forma que podria descargar los ficheros necesarios en windos xp y luego salir de windows y arrancar en el ubuntu e instalar y configurar desde ahi lo necesario para que el dichoso modem trabaje con simyo, he escrito varias veces a los de simyo pero no hacen caso, gracias por todo y buena suerte para todos, miguel

fran said...

@spain, el modemmanager lo puedes descargar de:
http://ppa.launchpad.net/jmartinj/x060-karmic/ubuntu/pool/main/m/modemmanager/
y el usb-modeswitch de:
http://packages.ubuntu.com/karmic/usb-modeswitch

fran said...

Supongo que sabes que debes elegir el paquete correspondiente a tu instalación de Karmic, si es de 32 bit, el que su nombre termina por i386.deb y si es de 64 bit el que termina por amd64.deb
Si al tratar de instalarlos te avisara de que te falta alguna dependencia, buscas esas dependencias en el segundo enlace que te he pasado (tiene un buscador de paquetes arriba).

Felipe said...
This comment has been removed by the author.
Felipe said...

¿Se sabe si en Ubuntu 10.04 el modem funciona por defecto?

En caso de que no sea así ¿Éstas instrucciones sirven para el nuevo Ubuntu?

Gracias.

Javi said...

He mirado el nuevo paquete modemmanager en lucid y han cambiado cosas respecto a la detección del X060. Tiene pinta de que debería funcionar en una instalación limpia (por fin).

Yo el módem lo tengo roto y no lo puedo probar, a ver si alguien comenta algo...

Felipe said...

Hola Javi.

Te cuento lo que hice:

Como no me detectaba el alcatel como modem, instalé los siguientes paquetes:

http://packages.ubuntu.com/lucid/usb-modeswitch

http://packages.ubuntu.com/lucid/usb-modeswitch-data

Ahora me lo detecta como modem, pero sólo conseguí conectarme durante dos minutos. Luego estuve intentándolo y no había manera.
¿Me puedes dar algunas indicaciones de qué tengo que hacer?

Gracias y perdona las molestias.

fran said...

Mi experiencia con Lucid:
Tras actualizar sólo conseguía conectar con wvdial. Supuse que era cosa del modemmanager 0.3 que viene con Lucid y lo desinstalé para volver al 0.2 parcheado de este post, pero nm-applet seguía sin conectar. Ayer hice los cambios que proponen en el comentario 4 de este bug y hoy ha funcionado a la primera. Aún no he probado el modemmanager 0.3 tras ese cambio.

Felipe said...

Yo en Lucid he conseguido que funcionase instalando los paquetes:

http://packages.ubuntu.com/lucid/usb-modeswitch
http://packages.ubuntu.com/lucid/usb-modeswitch-data

Tal y se explica aquí:
http://novatillasku.com/2010/05/03/huawei-e1612-funciona-en-ubuntu-10-04/

Eso sí, tarda un poco en conectarse y a veces no puedes navegar, pero eso era algo que ya me pasaba en la versión 9.10. Lo único que hago es desconectar y conectar de nuevo ...

Felipe said...

Hola Fran, ¿podrías explicar de forma algo más detallada cómo has conseguido que funcione? Gracias.

Felipe said...

Por fin he conseguido que funcione el modem en Ubuntu 10.04, gracias a Fran y a Javi. Aquí están los pasos que he seguido:

http://felinfo.blogspot.com/2010/05/modem-alcatel-x060s-symio-en-ubuntu.html

Espero que le sirva a más gente.

Miquel said...

Hola, ante todo agradezco tu ayuda. He subido el contenido de los dos archivos en pastebin.com: http://pastebin.com/yVuUemSS
Quedo a tu espera, saludos.

Saúl said...

Luz Naranja parpadeando despues de haber seguido toooodos los consejos de aqui
Alcatel X060
Lucid Linux
que puedo hacer?

fran said...

BUENAS NOTICIAS.
En Maverick Meerkat mi Alcatel X060S funciona sin tocar nada, desde el live CD. He actualizado desde Lucid a Maverick y se acabaron los problemas. Viene con el modemmanager versión 0.4+git.20100809t153145.be280

Post a Comment